draft-ietf-oauth-selective-disclosure-jwt-17 - Selective Disclosure for JWTs (SD-JWT)
This specification defines a mechanism for the selective disclosure of individual elements of a JSON-encoded data structure used as the payload of a JSON Web Signature (JWS). The primary use case is the selective disclosure of JSON Web Token (JWT) claims.
RFC 9901 - Selective Disclosure for JSON Web Tokens Skip to main content Selective Disclosure for JSON Web Tokens RFC 9901 Status Email expansions History Document Type RFC - Proposed Standard (November 2025) Was draft-ietf-oauth-selective-disclosure-jwt ( oauth WG ) Authors D. Fett , K. Yasuda , B. Campbell Last updated 2026-05-20 RFC stream Internet Engineering Task Force (IETF) Formats txt html xml pdf htmlized bibtex Additional resources Mailing list discussion IESG Responsible AD Deb Cooley Send notices to (None) Email authors Email WG IPR References Referenced by Get editor source Search
related reading
- What are JWT, JWS, JWE, JWK, and JWA?loginradius.com
- RFC 7800 - Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)datatracker.ietf.org
- DIF Presentation Exchangeidentity.foundation
- RFC 6902 - JavaScript Object Notation (JSON) Patchdatatracker.ietf.org
- RFC 9700: Best Current Practice for OAuth 2.0 Securitydatatracker.ietf.org
- What is Private Key JWT: Deep dive into asymmetric client authentication — WorkOSworkos.com
- Building a BFT JSON CRDTjzhao.xyz
- Decentralized Identifiers (DIDs) v1.0w3.org
- RFC 6749: The OAuth 2.0 Authorization Frameworkdatatracker.ietf.org
- thesis.pdfaayushg.com
- Non-Revocation Tokenidentity.foundation
- ERC-1155: Multi Token Standardeips.ethereum.org